english greek

The Newbrain Forum

Anything about the Newbrain Home Computer

You are not logged in.

Add to: Mr. Wong Add to: Webnews Add to: Icio Add to: Oneview Add to: Folkd Add to: Yigg Add to: Linkarena Add to: Digg Add to: Del.icio.us Add to: Reddit Add to: Simpy Add to: StumbleUpon Add to: Slashdot Add to: Netscape Add to: Furl Add to: Yahoo Add to: Spurl Add to: Google Add to: Blinklist Add to: Blogmarks Add to: Diigo Add to: Technorati Add to: Newsvine Add to: Blinkbits Add to: Ma.Gnolia Add to: Smarking Add to: Netvouz Information

#1 08-08-2019 17:24:05

gillespienewbrain
New member

(Hover for details)
Registered: 27-11-2018
Posts: 1
Reputation :   

RS232 program loading

Hi,

I am quite new the the NewBrain and recently managed to repair a broken NB here in South Africa. I made a serial cable and wanted to load programs from a PC using PC2NB.exe or the emulator but I can't seem to find out what commands are needed to do this. I have tried OPEN#9,9 but that doesn't work so I'm not sure if I have the wrong commands or my cable is not working.

I have since found the info below on this site but when I issue OPEN#0,9 my screen just goes blank and doesn't return.

From another post I found:
"
On the Newbrain side you should open device 9 "open#0,9" and then type "Load#9" BEFORE pressing the SEND button on PC2NB.

You can also use the NB Emulator to make the transfer by using open#0,9 command on both (NB emu and NB).
Then you type Load#9 and Save#9 on either machine depending in which machine you have the program you want to send (use save) and where you want to load it through RS232.
"

Any guidance would be greatly appreciated.

Thanks
Stephen

Last edited by gillespienewbrain (12-08-2019 15:47:31)

 

#2 Yesterday 17:47:40

cdesp
Moderator

(Hover for details)
Location:  : Kilkis, Macedonia, Greece
Registered: 27-07-2008
Posts: 84
Reputation :   

Re: RS232 program loading

Hi Stephen,

if you have a good cable (check this on how it should be made http://www.newbrainemu.eu/resources/new … cable.html)
then this is what you should do to test it.

On the newbrain side open#9,9
On the Emulator Open#9,9
On the newbrain Print#9,"HI"
On the emulator Read#9,a$:?a$
Emulator should print HI if all is ok.

if nothing shows then you can make a program and start messing with your cable.

Code:

10 close#9:open#9,9
20 print#9,"HI":goto 20
run

on the emulator

Code:

10 close#9:open#9,9
20 read#9,a$:goto 20
run

those programs should run forever (until you press stop or break) so you can test the cable.

Because new pcs don't have serial ports if you are using a usb to serial cable be noted that some of them are not working as serial communication ports, I had to buy a pci RS232 expansion card to make it work.

Also at the options menu on the meulator you should select the serial port you are using and other params.
Newbrain uses 9600,N,8,1 by default.
You can change the flow control.

Hope this helps,

Chris

 


Add to: Mr. Wong Add to: Webnews Add to: Icio Add to: Oneview Add to: Folkd Add to: Yigg Add to: Linkarena Add to: Digg Add to: Del.icio.us Add to: Reddit Add to: Simpy Add to: StumbleUpon Add to: Slashdot Add to: Netscape Add to: Furl Add to: Yahoo Add to: Spurl Add to: Google Add to: Blinklist Add to: Blogmarks Add to: Diigo Add to: Technorati Add to: Newsvine Add to: Blinkbits Add to: Ma.Gnolia Add to: Smarking Add to: Netvouz Information

Forum Tools

Board information

Board statistics
Total number of registered users: 124
Total number of topics: 95
Total number of polls: 0
Total number of posts: 351
Total number of posts today: 1
User information
Newest registered user: chema
Registered users online: 2
Guests online: 544
Online: 
admin,
cdesp

Powered by Agora 1.0.4 Acropolis

© Copyright 2007 - 2008 Joomla Me!. All rights reserved.

Powered by Elxis - Open Source CMS.
Copyright (C) 2006-2019 Elxis.org. All rights reserved.